Die Klassenkonfiguration für dieses Gerät wird von Windows noch eingerichtet. (Code 56)

Seit dem Windows 10$ Fall Creators Update (Version 1709) kommt es immer wieder zu Problemen mit dem Netzwerkadapter oder den Drahtlosadaptern (WLAN und Bluetooth). Die Geräte sind dabei im Geräte-Manager mit einem gelben Warndreieck gekennzeichnet. Nach einem Rechtklick auf das betroffene Gerät und dem öffnen der Eigenschaften wird unter „Gerätestatus“ die Meldung „Die Klassenkonfiguration für dieses Gerät wird von Windows noch eingerichtet. (Code 56)“ angezeigt.

Potentielle Lösungen

Bei keinem der bei uns betroffenen Geräte hat es ausgereicht den betroffenen Adapter im Geräte-Manager zu deaktivieren. Auch ein Treiberupdate konnte das Problem nicht lösen.

In einigen Fällen hat es gereicht Software-Adapter wie den „VMware Network Adapter“ oder den „Check Point Virtual Network Adapter for Endpoint VPN Client“ über den Geräte-Manager zu deinstallieren. Nachdem der Adapter deinstalliert wurde, wurde unter „Gerätestatus“ die Meldung „Das Gerät funktioniert einwandfrei.“ statt „Die Klassenkonfiguration für dieses Gerät wird von Windows noch eingerichtet. (Code 56)“ angezeigt.

In anderen Fällen war es notwendig die Software, beispielsweise „Check Point Endpoint Security“, komplett zu entfernen. Wird die Software erneut installiert, kommt es unter Umständen erneut zu dem Problem.

Das Problem trat häufig in Kombination mit Dockingstations, überwiegend welche die per USB-C mit dem Notebook verbunden werden, auf.

 

Das könnte Dich auch interessieren …

8 Antworten

  1. Uli sagt:

    Vielen Dank für den Tipp! Nach zahlreichen Versuchen, die Treiber aktualisieren, hat dann die Deinstallation von Checkpoint geholfen.

  2. Tino S. sagt:

    Vielen Dank ebenfalls.

    Nach ca. 20h erfolgslosen suchen hat nur eine Deinstallation der Checkpoint-Software geholfen.

    Alles andere NICHT !
    Treiberupdate, Treiber vom Hersteller, Treiber deinstallieren, Neustarten, externe neue USB-WLAN Geräte, deinstallieren der Checkpoint-Netzwerkadapter >> alles ohne Erfolg !

    Danke Microsoft !!!

    Danke an diesen Blog…

  3. Kay sagt:

    Hallo,
    gibt es evtl. weitere Gründe für dieses Problem? Bei mir war/ist kein Check Point und/oder VMware installiert. Gibt es Tipps, wie ich nach Überbleibseln dieser beiden Tools suchen kann?

    Vielen Dank vorab.

  4. Alex sagt:

    Bei mir hat geholfen, Hyper V zu deinstallieren.

  5. Kay sagt:

    Vielen Dank Alex, leider ist Hyperlink V gar nicht installiert.
    Hast Du evtl. noch weitere Ideen?

  6. Kay sagt:

    Hallo Stephan,

    nein hab ich geprüft. Ist nichts installiert.
    Interessant ist evtl: rufe ich den VPN Eintrag in den Windows Netzwerkeinstellungen auf dauert es Minuten bis es geöffnet wird.

  7. André sagt:

    Super Tipp! Danke… Deinstallation hat geholfen!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.